[smesh-users] Issues with autodiscovery...

Paul Adams paul.adams at firsttruck.ca
Tue Jun 30 19:26:03 EDT 2009


Hi,

I have 3 WRT54GL's to test SMESH.  I downloaded the modified firmware & installed it - & then installed / configured SMESH.

Within the smesh.conf file - if I set the Neighbors setting to "-a ip -a ip" - SMESH works.

If I try to use "-d 255.5.5.5" or "-d 255.0.0.1" - then SMESH runs without error but the spines.snapshot file shows it cannot connect to other nodes.

When trying to specify autodiscovery - I also enter the settings for "prism0" and "35" in the following 2 sections below Neighbours.

Maybe I'm not setting the values for autodiscovery correctly.  I search the 'Net and a value of 255.0.0.1 should search every address in that entire subnet - is that correct?


I'm not sure where I'm going wrong.  If it helps - the 3 wireless SMESH nodes are set to 10.10.10.10, 10.10.10.11, 10.10.10.12 respectively.



Also - I'd like to maximise performance for VoIP using these routers.  Should I be using option 3 from the README file...

3. KERNEL REDUNDANT MULTIPATH MODE:  SMesh manages the network topology and the clients, but data packets are routed through the kernel.  This mode utilizes almost no CPU.  It employs overlay
 multicast inside the mesh through the kernel.  The SMesh iptables kernel patch and modules are needed for this mode to work (available through our website).  The full speed of the network
 is attainable in this mode when using low cost routers.



Thanks in advance for any help...


Regards

Paul Adams



More information about the smesh-users mailing list